HTTP/Protocol Settings are not applied


#1

Hi,

I am using XLT 4.9.0 and firefox. I would like to use the HTTP Proxy Settings, because external urls should be called via proxy, internal not.

I set the following properties:
com.xceptance.xlt.proxy = true
com.xceptance.xlt.proxy.host = X.Y.Z
com.xceptance.xlt.proxy.port = 8080
com.xceptance.xlt.proxy.userName = XYZ
com.xceptance.xlt.proxy.password = XYZ
com.xceptance.xlt.proxy.bypassForHosts = localhost 127\.0\.0\.1 ^192[.]168

When running the test via Jenkins the properties seems to be not applied:

  • I reach an internal url
  • I can not reach an external url, probably because proxy is not used.
  • When I commented out “com.xceptance.xlt.proxy.bypassForHosts” the internal url was reached. According to properties the proxy should be used and than the internal url should not be reached.

I see the properties at log file, so they are loaded, but not applied.

Is there anything else what must be considered and / or configured?


#2

Hi,

The properties you have set, will only be effective when you use XltDriver or XLT’s Action API.

As you want to configure Proxy settings for Firefox, you’ll have to pass the appropriate capabilities to FirefoxDriver constructor:

final String myProxy = "localhost:8080";
final org.openqa.selenium.Proxy proxy = new org.openqa.selenium.Proxy();

proxy.setHttpProxy(myProxy).setSslProxy(myProxy);

final DesiredCapabilities caps = new DesiredCapabilities();
caps.setCapability(CapabilityType.PROXY, proxy); 

WebDriver driver = new FirefoxDriver(caps);

Execution with the xlt web-driver failed
#3

Thank you for your very fast reply. I tried to use the XltDriver and the proxy config was applied. My tests were able to reach an internal and external webpage. Thanks a lot for the support.

Regards Christine


#4

That’s good news! I’m glad I could help.

Thanks,
Hartmut


closed #5

This topic was automatically closed 6 hours after the last reply. New replies are no longer allowed.