Issue to run Webdriver tests with Firefox 43 or higher


#1

With Firefox version 43, Mozilla switched on the strong requirement to run only signed addons. Because the Selenium/Webdriver-addon is not signed, there is currently only one option to get it running; by switching off the signed-addon-requirement.

Because XLT 4.5.8 does not yet contain the latest Selenium version that already deactivates the addon-requirement automatically, here is the step by step approach to patch your test suite to support that.

  • Create a directory <your-test-suite>/patches/classes/org/openqa/selenium/firefox
  • Put this file there, of course unzip it before. It will be a JSON file: webdriver_prefs.json.zip (1006 Bytes)
  • Add <your-test-suite>/patches/classes to your classpath definition in Eclipse or ANT (or any other tool you use). Make sure it comes before all the libraries you load from XLT. In Eclipse, you have to reorder this classpath entry and bring it to the top.
  • You made it, FF works again with Selenium und XLT.

XLT 4.6 is going to contain the latest and greatest Selenlum version, hence this is not longer needed then.

This will only work for FF 43 because this option will go away with FF 44. No idea what will happen afterwards and how the Selenium community will address that.


pinned globally #2

#3

To reorder the classpath entry for Eclipse you could edit the hidden project file .classpath for example.


#4

Hint for ANT based execution. Please add pathelement location patches/classes to your classpath definition in the build.xml file:

<!--
    Builds the test suite class path for further reference.
-->
<path id="test.suite.classpath">
    <pathelement location="patches/classes" /> 
    <path refid="xlt.classpath"/>
    <pathelement location="${test.classes.dir}"/>
    <fileset dir="${test.lib.dir}">
        <include name="*.jar"/>
    </fileset>
</path>

#5

Please note that there is still an open Selenium issue with 64-bit-version of firefox.

Read more about it here.