Navigation through the tree starts on top every time


#1

While navigate through the script tree with the keyboard the user can expand and collapse the scripts line by line. If the user is on the right site inside of a script the selection is still on the position, where the user expand or collapse the line. Is the user in the left tree of the script modules and collapse one the selection is jumping to the top and the user has to start there (if he navigate with the keyboard up and down).

When I collapse a module on the left site I want that the selection is still in the line, where I was. The work with the keyboard is really circuitous.

I “hope” this is a bug and not a feature and can be fixed in the next versions.
Thanks.


#2

Hi Ronny,

Could you please check whether you have the option ‘Link with Editor’ turned on?

If this is the case then each selection in the explorer view causes a (re)selection of the appropriate script editor tab on the right. I guess that this is causing your “selection jumps”.

Thus, please deactivate this option and check if this fixes your issue.

Thanks,
Hartmut


#3

Hi,

yes, this option was selected, but it is not the reason, why the selection jumps.
I have disabled it and it also jumps.
It do not jump to an other module; it jumps always to the top op the tree (on the line “(default package)”)

Please do the following steps:

  1. expand one module in the tree
  2. select the deepest module
  3. press the left key on the keyboard
    –> the package over the module is selected
  4. press the left key again
    –> the package is closed (ok)
    –> the selection is not visible anymore (I think this is wrong)
  5. press the down key
    –> you are on the top of the tree

I hope these steps help you to reproduce the issue.
Thanks.


#4

Roger that. I’ll take a look.
Thanks for the update and esp. for the Steps to Reproduce.

Thanks,
Hartmut


#5

Fixed in XLT Script Developer 4.7.3.


closed #6