Why read time out exception happens ? if read time out exception happens can we capture status code?

Hi team ,

When i run load test getting read timeout exceptions ,Can we increase timeout period , can we capture the status code and when the read timeout happens ?

sumanth P

I have set this to 35 sec is this correct ?

Depends on the timeout we are talking about. I think you are rather talking about:

## The connection timeout [ms] on sockets and establishing the connection. This
## value is used therefore twice. So a value of 30000 will set a timeout of 
## 30 seconds to establish the connection and 30 seconds on waiting for data.
## Default value is 100000 ms, if not set.
com.xceptance.xlt.timeout = 30000

And there is no status code for a timeout, because it is a timeout aka a non-response from the server side and the client cuts the cord because it takes too long.

may i know about where the timeout happening ? and in which Service call is Failing ?

I have used try and catch blocks to capture exception and need to capture which service call is failing and XltLogger.runTimeLogger.error(e.getClass());
where the capture info will get saved ?

Don’t capture these, because you interrupt the flow of your test case and suppress error reporting by the tool. XLT takes care of capturing these and providing information in the reports and logs. Or at least rethrow the exception after logging.

When you run a test, you can download all logs with the 1) option when you download results. Each agent stores the log files in its directory you will then find in the results.


We are checked the real browser for read timeout exceptions and socket timeout exceptions while running the load test we checking every page by group of people and the pages are quick its not taking more then 20 sec
After the complete load test i can see lot of issues with read timeout exceptions and socket timeout exceptions .
May i know why this is happening ? and how to disable javascript permanently in our script ?

See default.properties

com.xceptance.xlt.loadStaticContent = false
com.xceptance.xlt.cssEnabled = false

com.xceptance.xlt.javaScriptEnabled = false

Socket and read timeouts are likely not related to any JS. If not all requests run into timeout, it is often hard to find that in the browser at the same time. Mind sharing the report?

Hi @rschwietzke thank you for taking the time to look into the issue. Appreciate your help very much. Could you let us know which part of the report you are looking for? We can provide you with the screenshots.

The strange part is that in the report we see the errors happening for over 10 mins with an error rate >40% (refer below) , but manually none of us saw any issue with the site while browsing the site.

Also to add the reason we think JS has something to do with the errors is that, we don’t see the issue when the datalayer.js is disabled in Salesforce.

When datalayer.js is turned on, we start seeing the read timeouts. But our developers are not sure why it could be causing an issue.

What does datalayer.js do? JS is not handled properly in HtmlUnit because it speaks an old JS dialect and does not support all DOM features. Load testing with JS requires a real browser but that eats resources like hell.

Please share the full report aka a browsable version, screenshots won’t help here. You can mail it (when < 25 MB) to support@xceptance.com.

Hi @rschwietzke , I have shared the test report in an email to support@xceptance.com. as requested.

datalayer.js is the inbuilt GTM module of SFCC. We are not calling it in our load scripts, but think it might be getting triggered during pageload. If the JS is disabled in our test will any of the JS which are part of the webpage get triggered?

There is a toggle in SFCC which we can use to turn off datalayer.js on the storefront website. When this is off, the test runs smoothly. But when it is on, we start seeing the Read timeouts. So not sure if this is an issue with our scripts, or if it is an issue on the server side.

I assume you test using the XLT HtmlUnit module and not using a real browser, don’t you? If you turn JS off, it is completely off. This is the recommended setting for HtmlUnit based testing.

Yes @rschwietzke, we are testing using the XLT HtmlUnit module.

Did you receive the test results sent to support@xceptance.com ? Do let me know if you need anything else. Thanks for your help!

Yes, I already responded to your email.

Thank you @rschwietzke !